• posted a message on Shaman Friend

    Sorry, I had planned to work on addons last weekend but didn't have time with Halloween.  I will try to get an update out very soon.

    Link Removed
  • posted a message on Shaman Friend

    Thanks for the suggestion, it is now on my to-do list.

    Link Removed
  • posted a message on Shaman Friend

    I was able to reproduce this issue and it seems to be really weird behavior from the change to GetSpellLink that I made.  Other addons and macros have seen the same issue with google although I didn't find anyone else's suggestion for a fix.

     

    For some reason, if I use GetSpellLink(select(4,...)) it gives the above error.  However, if I do:

    spell = select(4,...)

    GetSpellLink(spell)

    Then there is no error.  I have no idea why assigning an intermediate variable fixes the issue.

     

    I am testing this fix in r86.

     

    Edit: Testing of r86 seems to show the issue fixed.

    Link Removed
  • posted a message on Shaman Friend

    This doesn't have anything to do with other addons.  It had to do with the Chain Lightning spell ID changing for ele (but when I had looked up the old one to see if it changed it still existed, but I didn't notice that it was resto only now).

     

    I am testing a fix in r86 with the new ele chain lightning spell ID.

     

    Edit: Testing of packaged r86 does seem to solve the issue.

    Link Removed
  • posted a message on Shaman Friend

    Thanks for the bug report.  I will work on reproducing this issue this weekend and fixing it.

    Link Removed
  • posted a message on Shaman Friend

    I uploaded an initial version that works with Legion without any LUA errors that I have found and removes stuff that isn't used anymore.  Earth Shield and Lightning Shield tracking are still there in the code in case you have those talents.  I probably should re-organize the options by spec since practically everything is spec dependent now.

     

    I plan on adding configurable Maelstrom level alerts for Elemental and Enhancement.  If you have any other ideas that would be useful for Legion, please let me know.

     

    I just got into the beta this week so I haven't had a lot of time to figure out what will be useful yet.

    Link Removed
  • posted a message on Shaman Friend

    I'm not sure I understand the issue.  I have mostly been playing resto on my shaman although I do have an enhance as offspec.  It sounds like the bug is with the set bonus.  So yes, I would have had to receive this report a bit earlier for it to be worth fixing it sounds like.  Thank you for your interest in ShamanFriend though.

    Link Removed
  • posted a message on GridStatusRaidDebuff2

    Sorry for the slow response, I need to check comments more often.  I am not sure what exactly you are saying.  If you want to open a bug request I can try to assist.  This addon works fine for Iskar Mythic; I have been doing the fight every week for months.

    Link Removed
  • posted a message on Shaman Friend

    I am investigating the issue with reflects.

    Link Removed
  • posted a message on WeakAuras 2

    I am still stuck on 2.1.0.6 if I don't want to constantly /reload to fix missing items in Blizzard's UI.  I have tried all the way to the latest 2.1.0.17.

    Is this strata(?) issue ever going to be fixed?

    Link Removed
  • To post a comment, please or register a new account.