• posted a message on XLoot
    Quote from quixadhal >>

    One feature I'd love to see is a "loot all, destroy grey" option for skinning.  It's always annoying to have to hand-loot a bunch of stuff that you KNOW will get vendored or more likely hand-tossed when your bags fill up, so that you can skin the corpse.

     You can't destroy items on the corpse directly, so while I see it's definitely a useful idea it's also not a purely loot related thing.
    I think there's addons that will maintain a minimum of bag space by deleting your cheapest greys already, but I don't have a name on hand.
    Link Removed
  • posted a message on XLoot
    Quote from aalwein >>

    Thank you for the reply.

     

    I actually disabled XLoot for a trial run through a random dungeon and the notices persisted, so it mustn't be XLoot. I'm not sure which one it is but given its just a little chat spam I'm not going to work to hard to find it. I just have too many addons to disabled one at a time to find it lol!

     Try a binary search - search by halves of your list. Disable half. If fixed, disable all except half of what you just disabled. If not, disable half of remaining. Repeat.
    Link Removed
  • posted a message on XLoot
    Quote from aalwein >>

    When I'm in an instance group - be it a dungeon, raid, or even a quest scenario - I get a message in chat that "You aren't in a party" anytime I loot something. It isn't affecting the actual loot or the ability to get it, it's just a message in chat every single time I loot. Not sure if this is a code issue or a settings issue but I couldn't change any settings that would affect the outcome. I also tried resetting the options altogether, to no avail.

     I have no idea what's going on there, but I'll look into it.
    If you could please try with only XLoot enabled for one bit where you know it happens and verify it still happens then, that would be great!
    Link Removed
  • posted a message on XLoot
    Quote from Howlin >>

    Hi and ty for this addon!

     

    I am getting this error every time I open the addon options in Interface, just sitting in town doing nothing.  The last thing I remember doing was trying to switch all my characters to a "default" profile and delete all other profiles. Not sure if that is the cause.

     

    1x XLoot_Frame\Frame.lua:566: bad argument #2 to 'format' (string expected, got nil)
    [C]: in function `format'
    XLoot_Frame\Frame.lua:566: in function `Update'
    XLoot_Frame\Frame.lua:188: in function `ApplyOptions'
    XLoot_Frame\Frame.lua:210: in function `func'
    XLoot_Options\Options-Options.lua:70: in function <XLoot_Options\Options.lua:67>
    XLoot_Options\Options-Options.lua:749: in function <XLoot_Options\Options.lua:746>
    [C]: in function `Show'
    FrameXML\InterfaceOptionsFrame.lua:28: in function `InterfaceOptionsList_DisplayPanel'
    FrameXML\InterfaceOptionsFrame.lua:46: in function `InterfaceOptionsListButton_OnClick'
    FrameXML\InterfaceOptionsFrame.lua:479: in function `InterfaceOptionsFrame_OpenToCategory'
    XLoot_Options\Options-Options.lua:767: in function `OpenPanel'
    XLoot\XLoot-7.0-8.lua:56: in function `ShowOptionPanel'
    XLoot\XLoot-7.0-8.lua:145: in function <XLoot\XLoot.lua:145>
    [C]: in function `Show'
    FrameXML\InterfaceOptionsFrame.lua:28: in function `InterfaceOptionsList_DisplayPanel'
    FrameXML\InterfaceOptionsFrame.lua:46: in function `InterfaceOptionsListButton_OnClick'
    [string "*:OnClick"]:2: in function <[string "*:OnClick"]:1>

    Locals:
    (*temporary) = "|c%s%s|r"
    (*temporary) = "ff9d9d9d"
    (*temporary) = nil
    (*temporary) = "string expected, got nil"

     I think I know why this is happening, and I'll have to re-write some of the code to avoid it.
    In the meantime, if you keep trying to open the options it should stop erroring at some point - WoW now un-loads item info and the options preview tries to show item info, breaking when it's already unloaded.
    Glad it's of use to you otherwise, and nice usage of spoiler tags.
    Link Removed
  • posted a message on XLoot
    Quote from Esper_86 >>

    A reset of the profile and a quick /reload did the trick.  Thanks!

     Glad that fixed it! Not sure what lead to it being an issue, but it didn't look like it was going to be fun to figure out :)
    Link Removed
  • posted a message on XLoot
    Quote from Esper_86 >>

    Hey there,

     

    Since the latest update, I've been having an issue where the names of looted items are not appearing correctly. 

     

    Here is a screenshot: https://postimg.org/image/gkbyn0wfz/

     

    Would this be an error on my end?  This happens without other addons active as well.

     

    Regards,

    Esper

     I'm not sure, I haven't seen that issue before. Could you try resetting Xloot's settings to default?
    Link Removed
  • posted a message on XLoot
    Quote from demonrage >>

    you mean i have to mess with xml files or something?

     

    happy to do that if anyoen knows how exactly.

     

    i just don't want to stop using it and i don't want the look of that loot frame :(

     That means it would be a lot of work and is possible to do but I do not do it in XLoot and have no plans to do it, I'm sorry.
    Link Removed
  • posted a message on XLoot
    Quote from demonrage >>

    Hi,

     

    i love this addon and all it does, but i still would like to have my loot window use the old default skin, i just want it stretched instead of in pages, is that possible?

     

    thanks.

     Theoretically possible but XLoot does not do this.
    Link Removed
  • posted a message on XLoot
    Quote from PaulSux >>

    how do i move the loot away from the middle of the screen?

     Turn off snapping and drag the frame.
    Link Removed
  • posted a message on XLoot

    Please try the new version.

    Link Removed
  • To post a comment, please or register a new account.