• posted a message on Legion Wardrobe
    Quote from niennasilll >>
    Quote from ykiigor >>

    This feature is not planned

     

    I understand but as a suggestion maybe you could integrate with Datastore for this feature.

     

    http://wow.curse.com/downloads/wow-addons/details/datastore.aspx

     Items in your mail wouldn't qualify anyway. You still have to bind them to your character to unlock the appearance.
    Link Removed
  • posted a message on MessageBoard

    Is there a way to edit the title of a topic? It seems like there should be, but I can't tell. 

    Link Removed
  • posted a message on Minimap Button Frame

    Happy to help! I've been noticing it for ages and never bothered to say anything or take the few minutes to poke around the code, so we're in the same boat there. It's a weird change to be certain, and odd that documentation hasn't been updated to reflect the new returns.

    Link Removed
  • posted a message on Minimap Button Frame

    Hey Bachlott - For some time now, I've been having trouble with the mail icon. It always shows that I have no new mail, even when I do. I did some poking through the code and found that a lot of places were checking HasNewMail() == 1. The only documentation I know of says that it should return 1 or nil, but when I actually print the function, I get true or false. When I changed the HasNewMail() checks in MBF, mail started displaying correctly for me again.

    As far as I know, even if it starts returning 1 again, if (HasNewMail()) should still work - any chance this could get bundled into the next build? I do like being able to see when I have new mail.

    Link Removed
  • posted a message on DataStore_Achievements

    I'm not entirely convinced that this is a problem directly caused by the code itself - I'm noticing that GetCategoryNumAchievements() is reporting having far more achievements than some categories actually have.

    1. Player vs. Player reports 38 total achievements, appears to have 34
    2. Shipyard reports 14 total achievements, appears to have 13
    3. Rated Battleground is reporting 19 total achievements, appears to have 17
    4. Arena is reporting 21 total achievements, appears to have 14.

    This is the source of the error, because GetAchievementInfo for IDs above the actual number in the category are returning a nil value, and there's no handling for nil achievement IDs - GetPreviousAchievement(nil) causes the error.

    It's hacky, but my solution to the problem was replacing line 182-190 with:

    if (achievementID ~= nil) then
    prevID = GetPreviousAchievement(achievementID)

    while type(prevID) ~= "nil" do
    local achievementID, _, _, achCompleted, month, day, year, _, flags,_, _, _, wasEarnedByMe, earnedBy = GetAchievementInfo(prevID)
    if not achievementID then break end -- exit the loop if id is invalid

    ScanSingleAchievement(achievementID, achCompleted, month, day, year, flags, wasEarnedByMe)
    prevID = GetPreviousAchievement(achievementID)
    end
    end

    Link Removed
  • posted a message on Master Plan

    I'd love some more info/documentation of this whole tab. I've been banging my head aganst the "mushroom icon" stat for a few days now, and even looking at the code I'm not sure what it does. I've figured out that it only shows up after... I think ten batch mission completions? The only other thing I'm guessing is that the value is a range between 1000 and 1250, though I don't know what it is or what it means.

    Link Removed
  • posted a message on Master Plan

    Same, it seems like the "Cache is almost full" detection is a little off. I'm sitting at 118 resources in my cache and it's blinking red.

    Think I figured it out - It always blinks red the first time because you have no "lastCheckedTime" set at that point. Picking up the current cache should stop this, I think.

    Link Removed
  • posted a message on Fishing Buddy

    I know you were testing some code for handling Fragrant Pheremone Fish, but that it got removed. Due to how time-sensitive they are, I know I've missed a few solely because I didn't realize that I'd looted them.

    Do you think you'd be willing to add something similar to the Pagle rep fish for when you pick up a pheremone fish? I shoehorned

    if ( id == 110508 and GSB("DingQuestFish") ) then
    PlaySound("MurlocDeepSea_Aggro", "master");
    end

    into my installation of Fishing Buddy - A bit of a hackjob, since it's not related to quest fish. 110508 is obviously the item ID for the Pheremone Fish itself.

    Link Removed
  • posted a message on PetTracker

    The issue seems to be a conflict with NPCScan.Overlay. Turn off that, and PetTracker works fine.

    Link Removed
  • posted a message on PetTracker

    Trying to poke around and see if I can find any possible causes. Odd question - Are the people with this problem using _NPCScan? Or, more specifically, _NPCScan.Overlay?

    Link Removed
  • To post a comment, please or register a new account.