• posted a message on WeakAuras 2

    Do anyone ever made a guide on how to make CPU friendly auras ? I recently started to reduce the CPU usage of my addons, and Weak Auras is now the first user of CPU but I think I have room for improvement with my auras.

     

    What's the most CPU friendly between having 2 auras (buff bars, icons) or merging them in a single one with custom code to change bar color ?
    Does it make any difference having unloaded auras in loaded groups ?
    Is there tips, tricks, to reduce WA CPU usage ?

    Cheers

    Link Removed
  • posted a message on Grid2

    Hey, I'm using Grid for years now. Should I download Grid2 ? Why using Grid2 over Grid ? Does it have something Grid doesn't have ?

    Link Removed
  • posted a message on MikScrollingBattleText

    I finaly managed to fix the problem.

    My MSBT profile was old and still tracking old removed spells. The error came from here : I deleted the old Nightfall trigger from my WTF\Account\Saved Variables\MikScrollingBattleText.lua and it's all good now !

    If someone got the same problem, here's what you have to delete from your profile (open it with Notepad++ or something like that) : 

    ["MSBT_TRIGGER_NIGHTFALL"] = {
    ["fontName"] = "MSBT Talisman",
    ["mainEvents"] = "SPELL_ENERGIZE{recipientAffiliation;;eq;;4026531840;;powerType;;eq;;7}",
    },

     

    Link Removed
  • posted a message on MikScrollingBattleText
    Quote from Natlyz >>

    I guess you should try to reinstall. Use the link in my comment below.

     

    Btw, I'm not getting any MSBT errors on my Rogue/Mage/Warlock.

    Killing Blow trigger, me killing a Squirrel during the Legion invasion.

     

     

     

    Really ? I'm getting an error everytime my warlock gets a soul shard from his abilities : 

    Message: ...rface\AddOns\MikScrollingBattleText\MSBTTriggers.lua:515: bad argument #1 to 'string_find' (string expected, got nil)
    Time: 08/19/16 08:56:25
    Count: 1
    Stack: [C]: ?
    ...rface\AddOns\MikScrollingBattleText\MSBTTriggers.lua:515: in function <...rface\AddOns\MikScrollingBattleText\MSBTTriggers.lua:506>
    ...rface\AddOns\MikScrollingBattleText\MSBTTriggers.lua:791: in function <...rface\AddOns\MikScrollingBattleText\MSBTTriggers.lua:727>
    ...rface\AddOns\MikScrollingBattleText\MSBTTriggers.lua:822: in function <...rface\AddOns\MikScrollingBattleText\MSBTTriggers.lua:804>

    Locals: (*temporary) = nil
    (*temporary) = "%n"
    (*temporary) = 1
    (*temporary) = true
    (*temporary) = "string expected, got nil"

     I'm not playing the game in english does it matters ?

    Link Removed
  • posted a message on MikScrollingBattleText

    Does it work for non-english users ?

    Link Removed
  • posted a message on Server Hop

    It looks like Blizzard made hopping happens only if you are in the same zone of the raidleader. Maybe Serverhop should display a text about it on login so everyone know ?

    Link Removed
  • posted a message on _NPCScan.Overlay

    Same here, announces for Tanaan big bosses don't work anymore.

    Link Removed
  • posted a message on Server Hop

    Maybe you can try to cut off your internet while the game is loading a character. Resets often occurs this way for me.

    Also I'm playing the game in french client, don't know if it matters.

    Edit: I just tried it, cord pulled my ethernet while game was loading a character, so loading get stuck at 90% and I got disconnected before reaching the world.
    Reset happened every time I did it. Hope it helps !

    Link Removed
  • posted a message on Server Hop

    Hi there

    The addon resets when I got disconnected or when game crash. Custom favourites are deleted, all options reset (checkboxes) and position too. Just like it's the first time I use the addon. Pretty annoying :/

    I'm using a lot (and I mean, A LOT) of addons and it's the only one that reset itself like that.

    Can be something wrong with the way Serverhop loads custom options on login ?

    Link Removed
  • posted a message on MikScrollingBattleText

    Hi ! Great add-on, using it since years !

    There is an error on my warlock when I get soulshards from my abilities :

    Message: ...rface\AddOns\MikScrollingBattleText\MSBTTriggers.lua:515: bad argument #1 to 'string_find' (string expected, got nil)
    Time: 08/07/16 19:46:57
    Count: 7
    Stack: [C]: ?
    ...rface\AddOns\MikScrollingBattleText\MSBTTriggers.lua:515: in function <...rface\AddOns\MikScrollingBattleText\MSBTTriggers.lua:506>
    ...rface\AddOns\MikScrollingBattleText\MSBTTriggers.lua:791: in function <...rface\AddOns\MikScrollingBattleText\MSBTTriggers.lua:727>
    ...rface\AddOns\MikScrollingBattleText\MSBTTriggers.lua:822: in function <...rface\AddOns\MikScrollingBattleText\MSBTTriggers.lua:804>

    Locals: (*temporary) = nil
    (*temporary) = "%n"
    (*temporary) = 1
    (*temporary) = true
    (*temporary) = "string expected, got nil"

     

    Link Removed
  • To post a comment, please or register a new account.